$re = '/(\d[\d_]+\d)/m';
$str = '302_pp_kamenno_seriy_brown.jpeg
yasen_beliy_523_2.jpg
bej_yasen_beliy_601.jpeg
bej_yasen_beliy_601_601_601.jpeg
bej_yasen_beliy_6_687_6.jpeg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);