const regex = /(\d[\d_]+\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d[\\d_]+\\d)', 'gm')
const str = `302_pp_kamenno_seriy_brown.jpeg
yasen_beliy_523_2.jpg
bej_yasen_beliy_601.jpeg
bej_yasen_beliy_601_601_601.jpeg
bej_yasen_beliy_6_687_6.jpeg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}