re = /(\d[\d_]+\d)/m
str = '302_pp_kamenno_seriy_brown.jpeg
yasen_beliy_523_2.jpg
bej_yasen_beliy_601.jpeg
bej_yasen_beliy_601_601_601.jpeg
bej_yasen_beliy_6_687_6.jpeg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end