using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d[\d_]+\d)";
string input = @"302_pp_kamenno_seriy_brown.jpeg
yasen_beliy_523_2.jpg
bej_yasen_beliy_601.jpeg
bej_yasen_beliy_601_601_601.jpeg
bej_yasen_beliy_6_687_6.jpeg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}