using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[A-Za-z][0-9][A-Za-z0-9]\.[A-Za-z0-9]{1,4}\b";
string input = @"A24.L text text
text A2F.L9 text text text
text text text A2F.LG4 text ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}