$re = '/\b[A-Za-z][0-9][A-Za-z0-9]\.[A-Za-z0-9]{1,4}\b/m';
$str = 'A24.L text text
text A2F.L9 text text text
text text text A2F.LG4 text ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);