const regex = new RegExp('\\b[A-Za-z][0-9][A-Za-z0-9]\\.[A-Za-z0-9]{1,4}\\b', 'gm')
const str = `A24.L text text
text A2F.L9 text text text
text text text A2F.LG4 text `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}