// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[A-Za-z][0-9][A-Za-z0-9]\.[A-Za-z0-9]{1,4}\b").unwrap();
let string = "A24.L text text
text A2F.L9 text text text
text text text A2F.LG4 text ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}