package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[A-Za-z][0-9][A-Za-z0-9]\.[A-Za-z0-9]{1,4}\b`)
var str = `A24.L text text
text A2F.L9 text text text
text text text A2F.LG4 text `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}