use strict;
my $str = 'A24.L text text
text A2F.L9 text text text
text text text A2F.LG4 text ';
my $regex = qr/\b[A-Za-z][0-9][A-Za-z0-9]\.[A-Za-z0-9]{1,4}\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}