import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "leakedbb\\.com\\-[0-9]+x[0-9]+.+[0-9]+x[0-9]+";
final String string = "leakedbb.com-1200x1600_67bd2cbd2fe26eab9480356a35c80eb9-1152x1536\n"
+ "leakedbb.com-1200x1600_67bd2cbd2fe26eab9480356a35c80eb9";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}