re = /leakedbb\.com\-[0-9]+x[0-9]+.+[0-9]+x[0-9]+/m
str = 'leakedbb.com-1200x1600_67bd2cbd2fe26eab9480356a35c80eb9-1152x1536
leakedbb.com-1200x1600_67bd2cbd2fe26eab9480356a35c80eb9'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end