const regex = /leakedbb\.com\-[0-9]+x[0-9]+.+[0-9]+x[0-9]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('leakedbb\\.com\\-[0-9]+x[0-9]+.+[0-9]+x[0-9]+', 'gm')
const str = `leakedbb.com-1200x1600_67bd2cbd2fe26eab9480356a35c80eb9-1152x1536
leakedbb.com-1200x1600_67bd2cbd2fe26eab9480356a35c80eb9`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}