import Foundation
let pattern = #"leakedbb\.com\-[0-9]+x[0-9]+.+[0-9]+x[0-9]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
leakedbb.com-1200x1600_67bd2cbd2fe26eab9480356a35c80eb9-1152x1536
leakedbb.com-1200x1600_67bd2cbd2fe26eab9480356a35c80eb9
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)