import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<td bgcolor=\"#EEEEEE\" align=\"center\"><input id=\"([-0-9a-zA-Z =~:#\\\"%>\\/<]*) ";
final String string = "<td bgcolor=\"#EEEEEE\" align=\"center\"><input id=\"selectedUser12\" type=\"checkbox\" name=\"selectedUser\" disabled value=\"sid759e0649e819999a3dc12a93ad2af5204a83f20600000000:cshah2op~~Admin%20Users\" ></td>\n"
+ " <td bgcolor=\"#EEEEEE\"> </td>\n"
+ " <td bgcolor=\"#EEEEEE\">cshah2op </td>";
final String subst = "$1 $2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}