re = /<td bgcolor="#EEEEEE" align="center"><input id="([-0-9a-zA-Z =~:#\"%>\/<]*) /m
str = '<td bgcolor="#EEEEEE" align="center"><input id="selectedUser12" type="checkbox" name="selectedUser" disabled value="sid759e0649e819999a3dc12a93ad2af5204a83f20600000000:cshah2op~~Admin%20Users" ></td>
<td bgcolor="#EEEEEE"> </td>
<td bgcolor="#EEEEEE">cshah2op </td>'
subst = '$1 $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result