using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<fontColor:#([a-z0-9]*)>(.*?)<\/fontColor>";
string input = @"<fontColor:#ff0000> January 30, 2011\n </fontColor><fontColor:#ff0010> Feb 1, 1999\n </fontColor><fontColor:#ff0050> Feb 2, 1970\n </fontColor>
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}