const regex = /<fontColor:#([a-z0-9]*)>(.*?)<\/fontColor>/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<fontColor:#([a-z0-9]*)>(.*?)<\\\/fontColor>', 'gim')
const str = `<fontColor:#ff0000> January 30, 2011\\n </fontColor><fontColor:#ff0010> Feb 1, 1999\\n </fontColor><fontColor:#ff0050> Feb 2, 1970\\n </fontColor>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}