import re
regex = re.compile(r"<fontColor:#([a-z0-9]*)>(.*?)<\/fontColor>", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("<fontColor:#ff0000> January 30, 2011\\n </fontColor><fontColor:#ff0010> Feb 1, 1999\\n </fontColor><fontColor:#ff0050> Feb 2, 1970\\n </fontColor>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")