$re = '/<fontColor:#([a-z0-9]*)>(.*?)<\/fontColor>/im';
$str = '<fontColor:#ff0000> January 30, 2011\\n </fontColor><fontColor:#ff0010> Feb 1, 1999\\n </fontColor><fontColor:#ff0050> Feb 2, 1970\\n </fontColor>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);