use strict;
my $str = '<fontColor:#ff0000> January 30, 2011\\n </fontColor><fontColor:#ff0010> Feb 1, 1999\\n </fontColor><fontColor:#ff0050> Feb 2, 1970\\n </fontColor>
';
my $regex = qr/<fontColor:#([a-z0-9]*)>(.*?)<\/fontColor>/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}