re = /<fontColor:#([a-z0-9]*)>(.*?)<\/fontColor>/im
str = '<fontColor:#ff0000> January 30, 2011\\n </fontColor><fontColor:#ff0010> Feb 1, 1999\\n </fontColor><fontColor:#ff0050> Feb 2, 1970\\n </fontColor>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end