#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)Start((?!Start).)*email1\@gmail\.com(.*?)End([^\n]*)"
Local $sString = "Start of a transaction." & @CRLF & _
"random line 1." & @CRLF & _
"random line 2." & @CRLF & _
"email1@yahoo.com # WRONG MAIL!" & @CRLF & _
"random line 3." & @CRLF & _
"End of a transaction." & @CRLF & _
"Start of a transaction." & @CRLF & _
"random line 1." & @CRLF & _
"random line 2." & @CRLF & _
"email1@gmail.com" & @CRLF & _
"End of a transaction." & @CRLF & _
"Start of a transaction." & @CRLF & _
"random line 1." & @CRLF & _
"random line 2." & @CRLF & _
"email1@yahoo.com" & @CRLF & _
"random line 3." & @CRLF & _
"End of a transaction." & @CRLF & _
"Start of a transaction." & @CRLF & _
"random line 1." & @CRLF & _
"random line 2." & @CRLF & _
"email1@gmail.com" & @CRLF & _
"End of a transaction."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")