# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Start((?!Start).)*email1\@gmail\.com(.*?)End([^\n]*)"
test_str = ("Start of a transaction.\n"
"random line 1.\n"
"random line 2.\n"
"email1@yahoo.com # WRONG MAIL!\n"
"random line 3.\n"
"End of a transaction.\n"
"Start of a transaction.\n"
"random line 1.\n"
"random line 2.\n"
"email1@gmail.com\n"
"End of a transaction.\n"
"Start of a transaction.\n"
"random line 1.\n"
"random line 2.\n"
"email1@yahoo.com\n"
"random line 3.\n"
"End of a transaction.\n"
"Start of a transaction.\n"
"random line 1.\n"
"random line 2.\n"
"email1@gmail.com\n"
"End of a transaction.")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.