using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Start((?!Start).)*email1\@gmail\.com(.*?)End([^\n]*)";
string input = @"Start of a transaction.
random line 1.
random line 2.
email1@yahoo.com # WRONG MAIL!
random line 3.
End of a transaction.
Start of a transaction.
random line 1.
random line 2.
email1@gmail.com
End of a transaction.
Start of a transaction.
random line 1.
random line 2.
email1@yahoo.com
random line 3.
End of a transaction.
Start of a transaction.
random line 1.
random line 2.
email1@gmail.com
End of a transaction.";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}