use strict;
my $str = 'Start of a transaction.
random line 1.
random line 2.
email1@yahoo.com # WRONG MAIL!
random line 3.
End of a transaction.
Start of a transaction.
random line 1.
random line 2.
email1@gmail.com
End of a transaction.
Start of a transaction.
random line 1.
random line 2.
email1@yahoo.com
random line 3.
End of a transaction.
Start of a transaction.
random line 1.
random line 2.
email1@gmail.com
End of a transaction.';
my $regex = qr/Start((?!Start).)*email1\@gmail\.com(.*?)End([^\n]*)/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}