const regex = /Start((?!Start).)*email1\@gmail\.com(.*?)End([^\n]*)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Start((?!Start).)*email1\\@gmail\\.com(.*?)End([^\\n]*)', 'gs')
const str = `Start of a transaction.
random line 1.
random line 2.
email1@yahoo.com # WRONG MAIL!
random line 3.
End of a transaction.
Start of a transaction.
random line 1.
random line 2.
email1@gmail.com
End of a transaction.
Start of a transaction.
random line 1.
random line 2.
email1@yahoo.com
random line 3.
End of a transaction.
Start of a transaction.
random line 1.
random line 2.
email1@gmail.com
End of a transaction.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}