import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Start((?!Start).)*email1\\@gmail\\.com(.*?)End([^\\n]*)";
final String string = "Start of a transaction.\n"
+ "random line 1.\n"
+ "random line 2.\n"
+ "email1@yahoo.com # WRONG MAIL!\n"
+ "random line 3.\n"
+ "End of a transaction.\n"
+ "Start of a transaction.\n"
+ "random line 1.\n"
+ "random line 2.\n"
+ "email1@gmail.com\n"
+ "End of a transaction.\n"
+ "Start of a transaction.\n"
+ "random line 1.\n"
+ "random line 2.\n"
+ "email1@yahoo.com\n"
+ "random line 3.\n"
+ "End of a transaction.\n"
+ "Start of a transaction.\n"
+ "random line 1.\n"
+ "random line 2.\n"
+ "email1@gmail.com\n"
+ "End of a transaction.";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}