re = /Start((?!Start).)*email1\@gmail\.com(.*?)End([^\n]*)/
str = 'Start of a transaction.
random line 1.
random line 2.
email1@yahoo.com # WRONG MAIL!
random line 3.
End of a transaction.
Start of a transaction.
random line 1.
random line 2.
email1@gmail.com
End of a transaction.
Start of a transaction.
random line 1.
random line 2.
email1@yahoo.com
random line 3.
End of a transaction.
Start of a transaction.
random line 1.
random line 2.
email1@gmail.com
End of a transaction.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end