#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\S+@\S+\.\S+"
Local $sString = "sam.drazin@gmail.com" & @CRLF & _
"paul@butthead.poo" & @CRLF & _
"gordon-ramsay@badass-chef.com" & @CRLF & _
"" & @CRLF & _
"jennifer.cutler@kellogg.northwestern.edu" & @CRLF & _
"" & @CRLF & _
"sam drazin@gmail.com" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"butthole@com" & @CRLF & _
"cooper.city.gov" & @CRLF & _
"" & @CRLF & _
"bunger.licksman@jibjab.tallywag" & @CRLF & _
"" & @CRLF & _
"corp^oral-misterman@sinbad.NAMM" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")