const regex = /\S+@\S+\.\S+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\S+@\\S+\\.\\S+', 'g')
const str = `sam.drazin@gmail.com
paul@butthead.poo
gordon-ramsay@badass-chef.com
jennifer.cutler@kellogg.northwestern.edu
sam drazin@gmail.com
butthole@com
cooper.city.gov
bunger.licksman@jibjab.tallywag
corp^oral-misterman@sinbad.NAMM
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}