using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\S+@\S+\.\S+";
string input = @"sam.drazin@gmail.com
paul@butthead.poo
gordon-ramsay@badass-chef.com
jennifer.cutler@kellogg.northwestern.edu
sam drazin@gmail.com
butthole@com
cooper.city.gov
bunger.licksman@jibjab.tallywag
corp^oral-misterman@sinbad.NAMM
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}