use strict;
my $str = 'sam.drazin@gmail.com
paul@butthead.poo
gordon-ramsay@badass-chef.com
jennifer.cutler@kellogg.northwestern.edu
sam drazin@gmail.com
butthole@com
cooper.city.gov
bunger.licksman@jibjab.tallywag
corp^oral-misterman@sinbad.NAMM
';
my $regex = qr/\S+@\S+\.\S+/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}