import re
regex = re.compile(r"\S+@\S+\.\S+")
test_str = ("sam.drazin@gmail.com\n"
"paul@butthead.poo\n"
"gordon-ramsay@badass-chef.com\n\n"
"jennifer.cutler@kellogg.northwestern.edu\n\n"
"sam drazin@gmail.com\n\n\n"
"butthole@com\n"
"cooper.city.gov\n\n"
"bunger.licksman@jibjab.tallywag\n\n"
"corp^oral-misterman@sinbad.NAMM\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")