$re = '/\S+@\S+\.\S+/';
$str = 'sam.drazin@gmail.com
paul@butthead.poo
gordon-ramsay@badass-chef.com
jennifer.cutler@kellogg.northwestern.edu
sam drazin@gmail.com
butthole@com
cooper.city.gov
bunger.licksman@jibjab.tallywag
corp^oral-misterman@sinbad.NAMM
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);