package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\S+@\S+\.\S+`)
var str = `sam.drazin@gmail.com
paul@butthead.poo
gordon-ramsay@badass-chef.com
jennifer.cutler@kellogg.northwestern.edu
sam drazin@gmail.com
butthole@com
cooper.city.gov
bunger.licksman@jibjab.tallywag
corp^oral-misterman@sinbad.NAMM
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}