# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=E-\d\d)(?=-\d+.)/,/gm;t' <<< "0.4066145E-07-0.3677403
0.4066145E-07-0.345465E-07"