re = /(?<=E-\d\d)(?=-\d+.)/m
str = '0.4066145E-07-0.3677403
0.4066145E-07-0.345465E-07'
subst = ','
result = str.gsub(re, subst)
# Print the result of the substitution
puts result