using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=E-\d\d)(?=-\d+.)";
string substitution = @",";
string input = @"0.4066145E-07-0.3677403
0.4066145E-07-0.345465E-07";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}