import Foundation
let pattern = #"(?<=E-\d\d)(?=-\d+.)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0.4066145E-07-0.3677403
0.4066145E-07-0.345465E-07
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #","#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)