use strict;
my $str = '0.4066145E-07-0.3677403
0.4066145E-07-0.345465E-07';
my $regex = qr/(?<=E-\d\d)(?=-\d+.)/mp;
my $subst = ',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";