$re = '/(?<=E-\d\d)(?=-\d+.)/m';
$str = '0.4066145E-07-0.3677403
0.4066145E-07-0.345465E-07';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;