#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=E-\d\d)(?=-\d+.)"
Local $sString = "0.4066145E-07-0.3677403" & @CRLF & _
"0.4066145E-07-0.345465E-07"
Local $sSubst = ","
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)