# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!fits|for)(\b\s+\d\d-\d\d\s+)(Caterpillar|Ford)(?!.*\S)/\1fits \2/gm;t' <<< "ABC123 08-10 Caterpillar
ABC123 fits 08-10 Caterpillar
ABC123 for 08-10 Caterpillar XYZ789"