const regex = /(?<!fits|for)(\b\s+\d\d-\d\d\s+)(Caterpillar|Ford)(?!.*\S)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!fits|for)(\\b\\s+\\d\\d-\\d\\d\\s+)(Caterpillar|Ford)(?!.*\\S)', 'gm')
const str = `ABC123 08-10 Caterpillar
ABC123 fits 08-10 Caterpillar
ABC123 for 08-10 Caterpillar XYZ789`;
const subst = `\1fits \2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);