#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!fits|for)(\b\s+\d\d-\d\d\s+)(Caterpillar|Ford)(?!.*\S)"
Local $sString = "ABC123 08-10 Caterpillar" & @CRLF & _
"ABC123 fits 08-10 Caterpillar" & @CRLF & _
"ABC123 for 08-10 Caterpillar XYZ789"
Local $sSubst = "\1fits \2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)