$re = '/(?<!fits|for)(\b\s+\d\d-\d\d\s+)(Caterpillar|Ford)(?!.*\S)/m';
$str = 'ABC123 08-10 Caterpillar
ABC123 fits 08-10 Caterpillar
ABC123 for 08-10 Caterpillar XYZ789';
$subst = "\1fits \2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;