use strict;
my $str = 'ABC123 08-10 Caterpillar
ABC123 fits 08-10 Caterpillar
ABC123 for 08-10 Caterpillar XYZ789';
my $regex = qr/(?<!fits|for)(\b\s+\d\d-\d\d\s+)(Caterpillar|Ford)(?!.*\S)/mp;
my $subst = '\\1fits \\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";