import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!fits|for)(\\b\\s+\\d\\d-\\d\\d\\s+)(Caterpillar|Ford)(?!.*\\S)";
final String string = "ABC123 08-10 Caterpillar\n"
+ "ABC123 fits 08-10 Caterpillar\n"
+ "ABC123 for 08-10 Caterpillar XYZ789";
final String subst = "\\1fits \\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}