re = /(?<!fits|for)(\b\s+\d\d-\d\d\s+)(Caterpillar|Ford)(?!.*\S)/m
str = 'ABC123 08-10 Caterpillar
ABC123 fits 08-10 Caterpillar
ABC123 for 08-10 Caterpillar XYZ789'
subst = '\\1fits \\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result